Bonjour,

Vous êtes plusieurs à nous avoir remonté des problèmes de chargement de contrôles ActiveX dans les pages de PWA après l’installation du Service Pack 3 et du CU d’octobre 2011.

Ce problème a été reproduit à notre niveau et la correction est en cours. Nous n’avons, pour le moment, pas de solution de contournement mais nous travaillons sur ce sujet. Je vous tiendrai informer de l’évolution de nos recherches.

En attendant, je vous propose cette solution temporaire afin d’éviter que PWA ne fasse une vérification des contrôles Active X :

  1. Allez dans le répertoire C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\LAYOUTS\PWA\LIBRARY
  2. Faites une copie du fichier SHELL.JS en SHELL.SAV
  3. Ouvrez le fichier SHELL.JS dans NOTEPAD et modifiez les deux lignes suivantes :
    • function PJ_CompareBuildVersion(clientBuildVersion, serverBuildVersion)
    • {
    •    var rgClientBuildVersion = clientBuildVersion.split(",");
    •    var rgServerBuildVersion = serverBuildVersion.split(",");
    •    for(var i = 0; i < rgClientBuildVersion.length-1; i++)
    •    {
    •       if(rgClientBuildVersion[i] > rgServerBuildVersion[i])
    •          return 0;
    •      if(rgClientBuildVersion[i] < rgServerBuildVersion[i])
    •          return 0;
    •    }
    •    return 0
  4. Sauvegardez le fichier SHELL.JS
  5. Dans IE, rechargez les pages (CTRL+RELOAD) de PWA utilisant la Grille (Centre de projets, Centre de ressources etc…). Vous devriez voir apparaitre la grille :

    clip_image001

Nous sommes désolés pour la contrainte créée par ce problème.

IMPORTANT : Ce problème est corrigé dans le Cumulative Update de décembre de Project Server 2007.

Bonne journée,

Marc Biarnès