Security Research & Defense -blogissa on uusi artikkeli, jossa kerrotaan DEP-toiminnosta (Data Execution Prevention) ja sitä, kuinka sitä voidaan hyödyntää Internet Explorer -selaimesta löytyneen haavoittuvuuden aiheuttaman riskin pienentämiseen. DEP on siis käyttöjärjestelmän toiminto, joka yhdessä koneen prosessorin kanssa estää ohjelmakoodin suorittamisen muistisivuilla, joita ei ole erityisesti merkitty niin, että ne sisältävät suoritettavaa ohjelmakoodia. Toiminto auttaa suojaamaan mm. Security Advisoryn 979352 mukaiselta IE-haavoittuvuudelta.

DEP-toiminto vaatii ensinnäkin, että käytössä oleva laitteisto tukee sitä. Useimmat nykyisin käytössä olevat tietokonelaitteistot tukevat toimintoa. Lisätietoa tuesta löytyy KB-artikkelista 912923. Toisekseen käyttöjärjestelmän on tuettava toimintoa, mikä tarkoittaa, että käyttöjärjestelmään on asennettava uusin saatavilla oleva Service Pack. Windows XP -käyttöjärjestelmällä varustettuihin järjestelmiin kannattaa siis päivittää Service Pack 3 ja vastaavasti Windows Vista -käyttöjärjestelmällä varustettuihin järjestelmiin kannattaa päivittää Service Pack 2.

Näiden perusvaatimusten lisäksi kannattaa huomata, että DEP on toiminto, joka on käytössä sovelluskohtaisesti. Internet Explorerin version 8 asennus ottaa DEPin käyttöön myös selaimessa automaattisesti. Jos käytössä on jokin aiempi IE-selaimen versio, on DEP otettava erikseen käyttöön. Tämä voidaan tehdä erityisesti Microsoftin tätä varten tarjoaman Fix It -toiminnon avulla. Fix It -toiminto lataa tässä tapauksessa koneelle MSI-tiedoston, jonka avulla DEP otetaan käyttöön IE-selaimessa automaattisesti. Lisätietoja Fix It -toiminnoista löytyy täältä.

Jos siis käytössäsi on vähintään Windows XP ja Service Pack 3, Windows Vista ja Service Pack 2 tai Windows 7 sekä Internet Explorer -selaimen versio 8, DEP on automaattisesti käytössä. Mikäli käytössäsi on jokin aiempi Service Pack -versio tai Internet Explorer -selaimen versio, on tietysti suositeltavaa päivittää tietokoneesi käyttöjärjestelmään uusin Service Pack ja sen lisäksi päivittää selain uusimpaan versioon. Jos tämä ei syystä tai toisesta ole mahdollista, ota DEP käyttöön täältä löytyvien ohjeiden mukaan.

Ja vielä tähän loppuun, Microsoft on tekemässä päivitystä haavoittuvuuteen, ja se julkaistaan heti, kunhan päivityksen testaus on saatu päätökseen. Lisätietoja aiheesta myös MSRC:n uusimmassa blogiartikkelissa.

Seuraa  Bärren  tietoturva-uutisia täältä: http://blogs.technet.com/tietoturvan_weblogi/