Forwarding on the 6to4 network interface cannot be enabled

Forwarding on the 6to4 network interface cannot be enabled

  • Comments 1
  • Likes

An error you might run into when activating a DirectAccess configuration is the dreadful “Forwarding on the 6to4 network interface cannot be enabled”:

clip_image002

This often happens after you rebuild a server, and try to restore a configuration from backup, and is typically caused because of a duplicate 6to4 interface.

The first step of resolving this is to enable the interface manually, which is done this way:

1. Find the name of your 6to4 adapter by running the command netsh int ipv6 show int. This would often be “6to4 adapter”

clip_image004

2. Enable forwarding by running the command netsh int ipv6 set int <NAME> forwarding=enabled where <NAME> is what you found in step 1

clip_image006

Now, try activating DA again from the UAG console. You would probably be disappointed to see it fail again. If so, the reason is probably because the computer has duplicate 6to4 adapters, confusing the server. If so, you can easily fix this by removing the interfaces from the Device Manager:

1. Open Device Manager

2. Click View and select “View Hidden Devices”

clip_image008

3. Notice the two 6to4 adapters? There’s your problem. Remove both of them by right-clicking and selecting “uninstall”.

4. Close the device manager, and reboot the UAG server.

5. After a reboot, the 6to4 adapter will be re-added, but only once, so you should be good to go.

6. Activate the UAG configuration again, and this time, it should be fine!

Blog post written by Ben Ari

Comments
  • Hi  I have simlar Problem but  I am getting Forwarding on the Teredo network interface cannot be enabled.    UAG 2010  DA Management EventId 10023     I did  1.At an elevated command prompt, type netsh int ipv6 show int. A list of the current interfaces is displayed.

    2.Type netsh int ipv6 set int “interface” forwarding=enabled where “interface” is the Teredo interface name and can be taken from the output created in step 1.

    If forwarding still cannot be manually enabled on the interface, use the resulting error message to troubleshoot the problem further.

    3.When forwarding is enabled, reactivate Forefront UAG.    

    But get same Problem

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment