Q:  I tried to install the KB928225 patch (Exchange 2000 CDO update). The patch failed and asked me to check the log. "First condition in rollup.andop.section failed" is what I found.

A:  Because of file dependencies, this hotfix requires Microsoft Exchange 2000 Server Service Pack 3 (SP3) and the August 2004 Exchange 2000 Server Post-Service Pack 3 Update Rollup.

To get Exchange 2000 SP3, refer to KB 301378 (http://support.microsoft.com/kb/301378 How to obtain the latest Exchange 2000 Server service pack)

To get Exchange 2000 August rollup, refer to KB 870540 (http://support.microsoft.com/kb/870540 Availability of the August 2004 Exchange 2000 Server Post-Service Pack 3 Update Rollup)