Doug Deitterick's Blog

Information about Microsoft Lync, OCS, and Exchange UM.

Error when Configuring Delegated Setup

Error when Configuring Delegated Setup

  • Comments 1
  • Likes

I had a customer run across this issue recently.  When trying to use LCSCmd to configure delegated setup, you would get the following error:

LCSCmd.exe /Domain[:<domain FQDN>]  /Action:CreateDelegation /Delegation:SetupAdmin  /TrusteeGroup:<name of the universal group that you will delegate to>  /TrusteeDomain:<FQDN of the domain where the trustee group resides> /ServiceAccount:<RTC service account name> /ComponentServiceAccount:<RTC component service account name> /ComputerOU:<DN of the OU or container where the computer objects that will run Office Communications Server reside>

Microsoft Office Communications Server 2007 R2 Deployment Command Console
Copyright (c) Microsoft Corporation.  All rights reserved.

Missing required argument
  /PoolName   Specifies the name of the pool.

ERROR (0xC3EC7941): Missing one or more required command line arguments.

Type lcscmd /? for help using this command.

 

The solution to this issue is an easy one.  In order for the command to complete successfully you need to add "/PoolName:" with no value specified.

Comments
  • Hi,

    what happens if you add the name of the pool, that does not exists AT THE MOMENT, but WILL EXIST when you start deploying it using the account that just received the delegated installer permissions?

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment