Two days ago, on TechEd Australia, a customer walked up to me with his delegate netbook in hand and a problem on his mind. He had been trying to install the ZTE-made modem on the netbook, but the built-in software kept complaining that it didn’t find any modem device.

Step 1 – First look and stepping through the install process

The modem in question is one of the kind of devices that can appear to the system in 2 different modes:

  1. For computers that don’t have any drivers installed, it looks like a USB CD-ROM drive that contains the driver files and installer
  2. As soon as the drivers get installed, the device gets recognised as it’s “real self” – a USB UMTS modem

On the customer’s computer, the device still looked like a CD-ROM, even though the Telstra Turbo Connection Manager software seemed to be correctly installed.

Re-running the setup yielded the same result

Step 2 – Taking a closer look

The install directory of the Telstra software contained 2 files that looked as if they could be the key to our problem:

USBDriverInstaller_x86.exe and USBDriverInstaller_x64.exe

However, running the appropriate x86 program didn’t change anything. Device Manager stayed static, no new device enumeration happened. The process simply exited, no error message, no outcome.

But there’s light at the end of the tunnel - looking into the “Drivers” subdirectory ultimately showed directories for “VISTA” and “WNET”, so the device should at least be Vista-ready, which makes it extremely likely that the drivers should work well in Windows 7 as well. I just needed a chance to get them installed correctly.

Step 3 – The idea and the solution

Right-clicking USBDriverInstaller_x86.exe and choosing “Properties” gives you a “Compatibility” Tab. Since the software seemed to be Vista compatible, I chose “Windows Vista” as compatibility mode for the driver installer.

Re-running the driver installer immediately yielded the right result – the USB CD-ROM disappeared and gradually became replaced by all the necessary sub-devices that make up the Modem device.

After that, the Connection Manager software recognised the device and a test connection to the internet succeeded without a hitch.

Step 4 – Assessment

It seems that the driver installer component checked for the OS version right at the start and simply exited without a message when noticing an unknown operating system (Windows 7). Windows 7 drivers for this device will surely fix that behaviour, let’s wait until after General Availability of Windows 7 and see if the manufacturer comes up with dedicated Windows 7 drivers.

Until then, fooling the install process into thinking it runs under Windows Vista should prove to be a valid workaround :)