Problem
=========
無法連線至伺服器 RMS。您已嘗試連線的伺服器與您的作業主控台不相容

image

Solution
==========
當您使用 Operations 主控台並嘗試連線至升級後的 Root Management Server 時可能會發生錯誤

使用 Operations 主控台連線至升級後的 Root Management Server (執行 Operations Manager 2007 R2) 時,可能會顯示下列錯誤訊息:

「管理群組 <管理群組名稱> 中安裝的伺服器版本 ('6.1.XXXX.X') 與組件版本 ('6.1.XXXX.X') 不相符。」

「無法連線至伺服器 "RMS 主機名稱"。您已嘗試連線的伺服器與您的作業主控台不相容。請確定用戶端和伺服器都使用相容的 Microsoft 簽署軟體版本。」

因應措施:將 Operations 主控台升級至 Operations Manager 2007 R2。如果這種做法不符合實際狀況,那麼您可以使用下列程序來停用版本檢查:

  1. 關閉 Operations 主控台。
  2. 在 Windows 桌面上,按一下 [開始],然後按一下 [執行]。
  3. 鍵入 regedit,然後按一下 [確定],啟動登錄編輯程式。

clip_image001注意

不當編輯登錄可能會對系統造成嚴重損害。在變更登錄前,您應先備份電腦上任何重要的資料。

  1. 瀏覽至 [HKey_CURRENT_USER\Software\Microsoft\Microsoft Operations Manager\3.0\Console]。

clip_image001[1]注意

確定您未對 HKEY_LOCAL_MACHINE 版本進行任何變更。

  1. 以滑鼠右鍵按一下 [Console],再按一下 [新增],然後按一下 [機碼]。
  2. 將 [新機碼 #1] 重新命名為 ManagementGroupSessionManager,然後按 ENTER。
  3. 以滑鼠右鍵按一下 [ManagementGroupSessionManager],再按一下 [新增],然後按一下 [DWORD 值]。
  4. 將 [新數值 #1] 重新命名為 DisableServerVersionCheck,然後按 ENTER。
  5. 以滑鼠右鍵按一下 [DisableServerVersionCheck],然後按一下 [修改]。
  6. 在 [編輯 DWORD 值] 對話方塊的 [數值資料] 文字方塊中輸入數字 1 (十進位,不是十六進位),然後按一下 [確定]。