Support Tip: ConfigMgr 2012 client goes to provisioning mode after running the ccmeval task

Support Tip: ConfigMgr 2012 client goes to provisioning mode after running the ccmeval task

  • Comments 2
  • Likes

image

Hi everyone, Arvind Kr. Rana here. I recently ran into an interesting issue and wanted to mention it here just in case anyone else happens to run into it. The problem is with the ccmeval task that is moving the CCM clients to provisioning mode, and what happens is the ProvisioningMode registry key changes to “True” after running the task.

Symptoms in Registry:

HKEY_LOCAL_MACHINE\Software\Microsoft\CCM\CcmExec
SystemTaskExcludes REG_SZ SchedulerStartup;SchedulerShutdown;SchedulerLogon;SchedulerLogoff;ClientRegistrationStartup
ProvisioningMode REG_SZ true

HKEY_LOCAL_MACHINE\Software\Microsoft\SMS\Mobile Client\Software Distribution\State
Paused REG_DWORD 0x1
PausedCookie REG_DWORD 0x225

When troubleshooting, we checked and found that the customer was using OSD to deploy Windows 7 and other OS’s onto unknown machines. In the process, those clients were first moving in to provisioning mode and then the Operating System was getting deployed onto them, and after that when the OS and the client was installed they would get un-provisioned again. However, the next day after the deployment, the ccmeval task ran and the client was moved back to provisioning mode.

We finally determined that we were facing this issue due to a bad task sequence. The OS was deployed and during the install the client used the user defined properties to install the ConfigMgr client. The mobileclient.tcf was modified for the purposes of OSD with the value “SMSPROVISIONINGMODE=1” but it did not change the value back after the OSD completed. Due to this, when ccmeval ran on the client and found “WMI Repository Integrity Test” failures, it re-installed the ConfigMgr client on the workstation, and while re-installing it used the same mobileclient.tcf that had the wrong value which caused the healthy client to move to provisioning mode.

Wrong Mobileclient.tcf:

[Client Install]

Install=INSTALL=ALL SMSCACHEFLAGS=PERCENTDISKSPACE SMSCACHESIZE=30 FSP=YYY SMSMP=YYY SMSPROVISIONINGMODE=1 SMSSITECODE=YYY

This normally happens when we needed to properly reboot the client and we use the Restart Computer action (time out = 0) or Run Command Line action (shutdown /r /t 0) with values for the timeout being less than 30 seconds. In this very short time, TS Manager is unable to finish the whole TS process including resetting provisioning mode and software distribution state.

Solution:

To resolve this issue, create a task sequence with a regular reboot time so that the above values have time to change back.

First, go to the problematic client and then the delete the local CCMSetup directory and do the client push or manually install client again so that the client downloads the new pristine client install files from the site server and then reinstall from the original source.

Once this completes, the issue should be fixed, and client should work normal.

More Information:

This problem can also manifest itself in other ways, so please first make sure that you make the appropriate amendments to the original Task Sequence and provide a proper reboot time so that the problem doesn’t occur at the first place.

The following TechNet article explains the OSD process: http://technet.microsoft.com/en-us/library/bb694101.aspx

Arvind Kumar Rana | Subject Matter Expert

Get the latest System Center news on Facebook and Twitter:

clip_image001 clip_image002

App-V Team blog: http://blogs.technet.com/appv/
ConfigMgr Support Team blog: http://blogs.technet.com/configurationmgr/
DPM Team blog: http://blogs.technet.com/dpm/
MED-V Team blog: http://blogs.technet.com/medv/
Orchestrator Support Team blog: http://blogs.technet.com/b/orchestrator/
Operations Manager Team blog: http://blogs.technet.com/momteam/
SCVMM Team blog: http://blogs.technet.com/scvmm
Server App-V Team blog: http://blogs.technet.com/b/serverappv
Service Manager Team blog: http://blogs.technet.com/b/servicemanager
System Center Essentials Team blog: http://blogs.technet.com/b/systemcenteressentials
WSUS Support Team blog: http://blogs.technet.com/sus/

The Forefront Server Protection blog: http://blogs.technet.com/b/fss/
The Forefront Endpoint Security blog : http://blogs.technet.com/b/clientsecurity/
The Forefront Identity Manager blog : http://blogs.msdn.com/b/ms-identity-support/
The Forefront TMG blog: http://blogs.technet.com/b/isablog/
The Forefront UAG blog: http://blogs.technet.com/b/edgeaccessblog/

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment
  • Thanks for article. It helped me to solve the problem and now I just know more. Thanks.

  • Thanks for article. It helped me to solve the problem and now I just know more. Thanks.