imageHere’s a new Knowledge Base article we published. This one talks about an issue where WDS installation images fail and are deleted when configured for multicast in System Center Configuration Manager 2007.

=====

Symptoms

Consider the following scenario:

1. You are using Windows Deployment Services in System Center Configuration Manager 2007 (ConfigMgr).

2. You are configured to use multicast.

3. You are deploying sparse files as part of your deployment.

In this scenario we see that some installation images get downloaded as sparse files. Because the initial hash is computed before the files are made sparse and the verification hash afterwards, both hashes are different. This leads to the deletion of the image and the failure of the install.

When you run into this problem will also see entries similar of the following in the SMSts.log file:

Found sparse part of the file: 5236588544 8192
File not processed completely. Partial results may exist.
Completed Extract File Succesfully
Download done setting progress bar to 100
Succesfully performed multicast download from mcs://<fqdn>/SMS_MCS/.sms_mcs?filePath=\\<fqdn>\SMSPKGD$\C0100978\&PackageFlags=134217728&packageID=C0100978&version=1
Hash could not be matched for the downloded content. Original ContentHash = ADB7A269FA5A45685BB67C7CFC933BB6D5A76D27, Downloaded ContentHash = 1F1748813C696136E1937A003115D70256015FB5
0L == TS::Utility::VerifyPackageHash(pszContentID, sDestination), HRESULT=80091007 (c:\qfe\nts_sms_fre\sms\framework\tscore\resolvesource.cpp,2903)

Cause

This occurs because WDS multicast does not support sparse files in the current release.

Resolution

In a pure WDS environment you can use wdsmcast.exe /usesparsefile:no to work around the problem. In ConfigMgr, currently the only option is to use unicast (i.e. disable multicast).

For more information on how multicast is enabled/disabled, see the following:

How to Enable Multicast for Operating System Deployment : http://technet.microsoft.com/en-us/library/cc161854.aspx

=====

For the most current version of this article please see the following:

2709963 - WDS installation images fail and are deleted when configured for multicast in System Center Configuration Manager 2007

J.C. Hornbeck | System Center & Security Knowledge Engineer

Get the latest System Center news on Facebook and Twitter:

clip_image001 clip_image002

App-V Team blog: http://blogs.technet.com/appv/
ConfigMgr Support Team blog: http://blogs.technet.com/configurationmgr/
DPM Team blog: http://blogs.technet.com/dpm/
MED-V Team blog: http://blogs.technet.com/medv/
Orchestrator Support Team blog: http://blogs.technet.com/b/orchestrator/
Operations Manager Team blog: http://blogs.technet.com/momteam/
SCVMM Team blog: http://blogs.technet.com/scvmm
Server App-V Team blog: http://blogs.technet.com/b/serverappv
Service Manager Team blog: http://blogs.technet.com/b/servicemanager
System Center Essentials Team blog: http://blogs.technet.com/b/systemcenteressentials
WSUS Support Team blog: http://blogs.technet.com/sus/

The Forefront Server Protection blog: http://blogs.technet.com/b/fss/
The Forefront Endpoint Security blog : http://blogs.technet.com/b/clientsecurity/
The Forefront Identity Manager blog : http://blogs.msdn.com/b/ms-identity-support/
The Forefront TMG blog: http://blogs.technet.com/b/isablog/
The Forefront UAG blog: http://blogs.technet.com/b/edgeaccessblog/