The knowledgebase article discussing the problem with installing System Center Essentials 2007 when :

•The computer on which you try to install Essentials 2007 has a domain suffix that does not match the fully qualified domain name (FQDN) of the domain. For example, the computer has a domain suffix of department.contoso.com. However, the domain is named contoso.com.

•The computer on which you try to install Essentials 2007 has a NetBIOS domain name that does not match the first part of the FQDN of the domain. For example, the NetBIOS domain name is CONTOSO-XYZ. However, the domain is named contoso.com instead of contoso-xyz.com.

has been released http://support.microsoft.com/?kbid=937831

A hotfix is now available to resolve the problem and is available from Microsoft Customer Support Services (CSS).

Please follow the instructions for installing the hotfix (discussed in the article) carefully. When the hotfix is installed on the proposed SCE server, files are copied to the installing users %Temp% folder and %Temp%\TempQFE. The hotfix MSI then completes. At this point the required files are in place which will be used to apply the ACTUAL hotfix during the Essentials setup process. Remaining logged on, run the SetupSCE.EXE from the folder/share containing the Essentials files and go through the setup wizard.  When the Reporting feature is installed, ACTUAL hotfix contained in the %Temp%\TempQFE will be applied.

The only noticable difference during the installation is an additional progress dialog that is displayed when Setup invokes the hotfix.  Below is a screenshot during the installation process. The reporting installation is in progress and the hotfix progess dialog is in the forground. In the background I had Process Explorer (www.microsoft.com/technet/sysinternals) running  which shows that SetupUpdateOM.exe has been launched from msiexec to apply the reporting hotfix during install.