A little less than 24 hours ago, I performed an in-place upgrade of my all purpose server from Windows Server 2008 R2 to Windows Server 2012 R2. It went surprisingly well and I had no issues with it for the remainder of the day.

This morning I checked it to see if anything popped up over night.  The only issue I saw were some System Event Log entires complaining that the integration services were different version between the host and the clients -

Networking driver in Gallifrey loaded but has a different version from the server. Server version 5.0  Client version 4.0 (Virtual machine ID F752825A-C87F-45E6-A80B-B35BE70E7505). The device will work, but this is an unsupported configuration. This means that technical support will not be provided until this problem is resolved. To fix this problem, upgrade the integration services. To upgrade, connect to the virtual machine and select Insert Integration Services Setup Disk from the Action menu.

I forgot about updating those so I performed those updates this morning. and gave the Hyper-V host another reboot for good measure.  All is well.

Keep in mind that the machine I did this in-place upgrade on had the following roles and Features

AD Domain Services (the machine is my “primary” DC)

Hyper-V (yea, yea, yea…..I shouldn’t have Hyper-V on a DC. I accept server donations)

DNS

File and Storage Services.

I don’t have a high use network nor do I have any unusual AD integrated apps that update the schema or add objects. But the server has been my production AD server for over 2 years now. I have added and removed software to it during that time and made a number of other tweaks over time. I am still amazed that it was so smoothly.

-Chris