Ethernet Driver Fix for Windows Server 2008 R2 on the Lenovo W510

Ethernet Driver Fix for Windows Server 2008 R2 on the Lenovo W510

  • Comments 1
  • Likes

10 days ago now I showed you how to install Windows Home Server 2011 RC as a virtual machine running in Hyper-V.  If you recall I installed Windows Server 2008 R2 on my Lenovo W510 laptop.  I had set aside some time today to do some testing with the Windows Home Server.  One of the questions I received in the comments of the previous post regarded the potential of joining a home group using shared Ethernet connections versus bridged wireless connections.  I decided to test both. 

So I booted the laptop and went to disable the wireless connection when I notice the Ethernet connection was not functioning.  Hmmmmmmmmm.  Upon further inspection the device manager and its accompanying Warning message told me that the Ethernet connection had not been configured correctly during setup.  No biggie, I can certainly install drivers. 

Famous last words.  This is no simple driver installation.  I tried to let it auto detect the right driver.  No dice.  I tried Windows update. No dice.  I tried downloading and installing the driver from Lenovo’s website.  The problem is that there is no Windows Server driver for the Ethernet controller.  I went with the 64 bit Windows 7 driver knowing the relationship between Windows Server 2008 R2 and Win 7.  Still no dice. 

In growing frustration I binged “ethernet driver windows server 2008 r2 Lenovo w510” and Shazaam!  Keith Combs has encountered this issue too, and he has posted the solution.  Leave it to Keith to document the solution.  I can’t tell you how many times in the past 7 years of working with Keith that he has given me valuable insights. 

To make a long story short I used Keith’s process with a couple of subtle changes (like the fact that the driver has updated) and the Ethernet connection works like a champ. 

Here is a the solution  excerpted from Keith’s Blog. 

“Install the Ethernet driver. This driver is not in the inbox drivers for Windows so you must download it. Like the T400 install I did, the package doesn’t install correctly so you have to do some manual work. Here are those steps:

  1. Run the 6irf10ww_v64.exe install.
  2. Launch R2 Server Manager and go to the device manager node.
  3. Right mouse click the banged out Ethernet nic.
  4. Select Update driver.
  5. Select browse my computer.
  6. Click “Let me pick from a list of device drivers on my computer”
  7. Click the “Have a disk” button
  8. Click the browse button
  9. Go to c:\drivers\win\ethernet\pro1000\winx64\ndis62
  10. Click e1k62x64.inf then click the open button
  11. Select the 82567LM-3 nic from the list and click the Next button (see screenshot below for the list displayed). Also note, other nics may work but this is what I am using until a better solution comes along.”

That fixes the Ethernet controller issues and now its off to the testing.

Comments
  • This solution worked for me, thanks

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment