the docs state it needs SQL 2008 with CU10 or higher.  I had CU10 installed but CM setup wouldn't get past the SQL version requirement.  Upgraded to CU13, install worked.  So, if you are installing CM2012 Beta 2, just install SQL 2008 with Service Pack 1 and install CU13 and you should be OK.  I'm sure these SQL version requirements will change once we get to RC or RTM.