The case of sidebar.exe not starting. Oh Snap!

The case of sidebar.exe not starting. Oh Snap!

  • Comments 9
  • Likes

Ran into a case today where each time we tried to start sidebar.exe it would fail silently.  No crash to investigate, no error, so where to next?

First I set an IFEO for sidebar.exe to launch windbg.exe when started, by doing this it stops at the initial breakpoint.

Secondly I enabled loader snaps to show me more information on module loads: c:\debuggers\gflags.exe -i sidebar.exe +sls. 

The show loader snaps flag captures detailed information about the loading and unloading of executable images and their supporting library modules and displays the data in the debugger.

 

After doing this and g'ing the debugger we could see that right before the process terminated it failed to load one particular dll:

LDR: LdrLoadDll, loading C:\Program Files\AVOne\AVOne 3GP Video Converter\atl.dll from C:\Program Files\AVOne\AVOne 3GP Video Converter;C:\Windows\system32
LDR: LdrpSearchPath - Looking for C:\Program Files\AVOne\AVOne 3GP Video Converter\atl.dll in C:\Program Files\AVOne\AVOne 3GP Video Converter;C:\Windows\system32
LDR: LdrpSearchPath - Unable to locate C:\Program Files\AVOne\AVOne 3GP Video Converter\atl.dll in C:\Program Files\AVOne\AVOne 3GP Video Converter;C:\Windows\system32: 0xc0000135
LDR: LdrpCheckForLoadedDll - Unable To Locate C:\Program Files\AVOne\AVOne 3GP Video Converter\atl.dll: 0xc0000135

Looking up the error code with err.exe:

C:\Debuggers\x86_ver>err 0xc0000135
# for hex 0xc0000135 / decimal -1073741515
STATUS_DLL_NOT_FOUND
# {Unable To Locate Component}
# This application has failed to start because %hs was not
# found. Re-installing the application may fix this problem.
# 1 matches found for "0xc0000135"

Once I had the user install the missing application (AVOne 3GP Video Converter) everything worked as expected.

 

Technorati tags: , , ,
Comments
  • Brad Rutkowski you're my hero

  • Join the club...

  • Stuff I've been intending to post a meaningful post about, but haven't: If you have ever wondered

  • Had a client whose machine would not load Windows Defender, each time it was opened it would eventually

  • Help.  I can start the siedbar, but all the geometries on the gadgets are broken - ie.  every gadget has all the screen stuff in the upper right corner.  It was working a few days ago, but now it has stopped.  any thoughts?

  • I figured it out.  When I installed Photoshop CS, it had me run a different java dll, which broke the sidebar.

  • I have a similar problem.  Had a virus on the computer & deleted some trojan virus named as dll's.  Specifically, the system is looking for 'olmhojkz.dll' and 'dcjolkdk.dll'.  Right now, I can't start any executables - they all fail silently.  Can you please help?  Thanks in advance!

  • Probably want to use an IFEO for that and capture the failure of the executable to start, but this might be a little in depth depending on your level of debugging.

    http://blogs.msdn.com/greggm/archive/2005/02/21/377663.aspx

  • Solving a problem like this when you're able to reproduce it is really simple.

    But what about my case? I'm a software developer and my company's product is widely used all around the world. Along development of course I also have to deal with maintenance tasks.

    Recently we've received several crash dumps from the Windows Error Reporting service. These dumps showed our module crashing in the process initialization phase. We saw two kinds of exceptions: the STATUS_DLL_NOT_FOUND (0xc0000135) and the STATUS_DLL_INIT_FAILED (0xc0000142).

    We're 100% sure which module wasn't found and which module's initialization failed in the other case. It was of course our DLL. But that's all we've got! Those crash dump files are hardly larger than 100kB. The call stack trace only shows calls in the ntdll module. We have absolutely nothing about how the crash could have happened, how we could reproduce it. (The only clue might be that the problem only came up on Vista (or above) and that in the case of the STATUS_DLL_NOT_FOUND an additional anti virus application's module were also loaded).

    So my question is, how one could start the investigation in such cases? And how these exceptions can happen in the first place?

    thanks in advance!

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment