Comme indiqué dans cet article, les iPhone sont supportés directement avec Exchange Online.

Toutefois, les personnes utilisant la version 4.0.0 de l'iPhone, sont obligées d'installer la mise à jour 4.0.1 pour résoudre un certain nombre de problèmes natifs à la version 4.0.0 ; cf. article d'Apple à ce sujet.

 A noter que si cette mise à jour n'est pas installée, les iPhone version 4.0.0 ne pourront pas se connecter sur Exchange Online ; ce problème m'affecte pas les iPhone version 3.x.