One of the best features of e-Gap and IAG is it's incredible flexibility with regards to localization. The login screen, for example, supports several languages out of the box, with no need for any configuration or tweaking. Just launch the login page, and use the drop-down to select either French, German or Spanish. It even saves your setting and will launch in the selected language next time you visit the site. However, the true flexibility is the customization. By editing an included language file, an administrator can translate the portal to virtually any language, as long as the code-page is supported by the browser. One can also modify the text of an already existing translation to match the organizations requirements. For example, an organization may want the company name to be included in the text, or to include a copyright or security notice.

 

 Blog - Client-side pop up is shown in English when other language is selected (006907) 

The customization procedure is covered well in the Advanced User Guide, so I won't details it fully here. Basically, all one has to do is locate the appropriate language file, and place it in a CustomUpdate folder. After activating the configuration, the new language will go into effect. To modify any specific text strings, just edit that same language XML file to your liking.

 

There is, however, a tiny issue with localization. While most of the text displayed by IAG is taken from the customizable language file, not all of it is. One issue that has come to our attention recently is the client-side texts. For example, in a scenario where an application is published using the Client/Server and Legacy Application template, the client is presented with a pop up saying Ready to launch application when she or he launches it from the portal page. This string, as well as the string that's shown in the Window title are hard coded, and are displayed in English even if the client has selected another language. The same also happens even if the Administrator has customized the texts completely.

 

What to do? Well, this might be fixed in future releases or updates, but until this happens, the only thing that can be done is to suppress that specific prompt completely. This is a good solution because many Administrators prefer that it doesn't show up regardless of the language option. Here's the procedure for eliminating the prompt altogether.

 

1. Locate the file SSLVPNTemplates.xml  in the folder \whale-com\e-gap\von\conf on the IAG Server

2. Backup the file to a secure location.

3. Locate the text "<exec exe=" " flags="256" default="yes"/>" under the "Generic simple relay - _requires_ hosts file support" section and remove it.

4. Save the file.

5. Click the IAG configuration activation button

6. Check the option "Apply changes made to external configuration settings