Installing Windows Vista Print Drivers on Windows Server 2003

Installing Windows Vista Print Drivers on Windows Server 2003

  • Comments 25
  • Likes

Good Morning AskPerf!  My name is John Dickson, and I am a Support Escalation Engineer on the Performance team in Texas.  Today we are going to discuss a scenario that is a common one as companies continue to deploy Windows Vista in their environment.  How do I deploy print drivers for Windows Vista onto a Windows Server 2003 print server?  We’re going to walk through the installation of the print drivers today.  Let’s dive right in, shall we?

There are two ways to install drivers, through the Vista Print Management Console or by opening a path to the Print Server Properties (\\Servername\Printers).  In either instance, File and Printer Sharing must be enabled and the appropriate ports have to be opened on the Vista Firewall.  Let’s start out by adding Vista drivers via the Print Management Console.

To load Vista x86 drivers on a Windows Server 2003 x86 print server, the steps must be performed from the Windows Vista machine by connecting to the Windows Server 2003 print server.

  1. Open the Print Management Console from Windows Vista SP1. Click the Vista button and type Print Management. Add the Windows Server 2003 Print server by Right Clicking Print Servers - Add/Remove Servers....

    PrintDrivers001

  2. Add the Windows Server 2003 Print Server

    PrintDrivers002

  3. Once, you’ve added the print server, select it in the Print Management Console (expand it), right click Drivers.  Click on Add Print Driver, click Next at the first screen of the wizard (shown below)

    PrintDrivers003

  4. Choose Processor Type, which in this case is x86 then click Next

    PrintDrivers004

  5. This will pull up the drivers on the Windows Vista machine (not the Windows Server 2003 Print Server)

    PrintDrivers005

  6. Choose the Microsoft Vista Inbox driver to install on the Windows Server 2003 Print Server
  7. Click Finish and this will copy the drivers to the Windows Server 2003 Print Server. Notice the driver version is 6.0.6000.xxxx which is how we know this is a Windows Vista / Windows Server 2008 Inbox driver.

    PrintDrivers006

As you can see, the procedure is not as daunting as you first might have thought!  It is actually fairly straightforward.  You can also add the drivers to the Print Server by opening a path to the Windows Server 2003 Server Printers share via \\Servername\Printers from the Windows Vista machine.

  1. Right Click Printers then select Server Properties

    PrintDrivers007

  2. The Print Server Properties page will be displayed and we need to click Drivers tab. From here we will click ADD.. to bring up the Add Printer Driver Wizard. (Notice we have a x64 driver on a x86 Windows Server 2003 Print Server)

    PrintDrivers008

  3. Click next and choose the processor architecture then printer driver. In this step, we will add a Dell Laser Printer x64 driver to the Windows Server 2003 Print Server which is running a 32-bit operating system (x86 architecture).

    PrintDrivers009

    PrintDrivers010

  4. The easiest way to see that Windows Vista drivers are installed on Windows Server 2003 is to use the Windows Vista SP1 / Windows Server 2008 Print Management Console which will show the processor architecture and Driver Version as seen below:

    PrintDrivers011

And that’s it!  Two fairly simple methods to deploy Windows Vista / Windows Server 2008 drivers to a Windows Server 2003 print server.  Hopefully this helps you out as you continue to deploy Windows Vista in your environment,

- John Dickson

Share this post :
Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment
  • It's wasting of time to fix the vista printing problem.

    I have a hp printer, it doesn't print well in vista. Sometimes the wording, or the line was not align properly.

  • I followed the above steps to install the Vista x64 drivers onto my 2003 R2 x32 print server. They show up in the console, but are not enabled as "additional drivers" by default in the printer properties. When I go and check the box to add them as additional drivers, I get prompted for the .inf files.

    I thought the whole purpose of adding them this way was so that you would not be prompted for the disk, no? Since I installed the drivers from the built-in drivers that are included in the Vista software, I do not have the separate .inf file that I know of.

    Could someone share some light?

    Thanks,

    Dave

  • i am experiancing the same issues as dave. i have added the drivers to the server but i cannot push them to vista clients. It keeps asking me for an INF file that i dont have seeing as i am using the built in vista driver.

  • I think I'm having the same problem as Dave and Ryan.  Installing the driver to the share appeared to work, but I can't actually select the shared printer from Vista without being prompted for "*.inf" which I have no idea where to find.

  • what if we wanted to add vista x86 printer drivers to a windows server 2003 x64 system.

  • Hi folks,

    the key to success, is to logon to the vista client with an account, which has admin rights on the printer server.

    Good luck.

    Nick

  • I'm trying to do this, but on a Windows 2000 print server.  Unfortunately, the W2K print server doesn't comprehend the x64 architecture, so my 64-bit drivers won't load.

    Is there a way to teach the W2K server a new trick, or must I put this beast out to pasture, and build a W2K3 print server?

  • I've tried the above method adding vista drivers to a 2008 server.  I can get all the way to the end of the wizard, and the driver appears to want to copy to the server.  However, there's some error that causes the copy to restart 3 times (at different places in the copy), and the wizard returns "Unable to install %print driver%.  Operation could not be completed (error 0x57)."

    I've disabled the vista filewall, and I can load vendor supplied drivers (for vista) through a 2003 client without a problem.  My hangup is that the drivers I need are only on the vista install.

  • I am trying to load vista drivers to windows 2003 Server Sp2. However when I add driver I get who errors

    Type 3 - User Mode,x86 Driver, Access is denied

    Failed to add driver. Operations could not be completed ( error 0x000000578)

    I am using the admin account thats local admin on both local machine (vista) as well as windows 2003 server

  • This is nice; however, I need to find a way to script the installation of printers in a fully automated mode.  I need to install 50 printers on 30 Windows 2003 servers.  I can't seem to get the WMI scripts to work due to security issues.  I was told that the WMI API calls are intended as READONLY properties and that I cannot install printers that way.  Is there an automated (non-GUI) method that can be scripted?

  • John,  (Vista 64 bit on Windows 2003 server).  I can get the drivers copied to the Windows 2003 x86 server, but like others in this post, when I use a Vista 64 bit computer to try to connect the printer, it always asked me for a printer driver.  I AM logging onto the server with credentials of administrator, but it won't download my drivers to the Vista machines.  The printer also does NOT have the 64x checked when I view it as though the printer I have installed on the print server can't find the x64 driver (even though it shows on my driver list).

    Has anyone resolved the above issues?

  • Same issue as Nembo.

    Using Server 2003 R2. Client is Windows 7, logged on with domain admin creds.

  • Gave up on that idea. Updated the HP universal print driver on the server, and and re-added to Windows 7, no longer crashes on setting printer options.

  • Same as everyone else - above process puts the drivers on Server 2003 sp2, but clients still do not get them. I can't seem to associate the driver with the printer so the driver is not downloaded to the Windows 7 (x64) clients when they try to add a network printer...

  • Guys,  I had the same problem as you - I put the drivers on the server but the clients would not get them.  This is how I resolved this (it's not pretty but works):

    Navigate to the folder you have the x64 drivers in and open the .inf for the print driver. Do a find and replace and rename the Printer name EXACTLY as the x86 driver displays the name.

    i.e. the x86 driver already installed was called "Dell Laser Printer M5300" (in the server properties window)

    The x64 driver was named "Dell Laser Printer M5300 XL" --> renaming this to "Dell Laser Printer M5300" in the inf BEFORE uploading to the server seemed to do the trick.

    I hope that helps.