Symptom:

A few customers reported the following issue:

Environment:

DPM 2010 installed on Windows2008 R2 SP1 with hyper-v enabled.

When the customers go to create a protection group that includes Hyper-V protection, they get an error message (ID: 31313) that you need to install the patch from KB975354. The problem is when installing this hotfix, it said “the update is not applicable to your computer”, then it is stuck and the users are unable to setup the backup for the Hyper-V guest VMs.

But the KB975354 is included in Service Pack 1.

Resolution:

The workaround is to fudge the DB, let DPM believes the windows 2008 R2 hotfix has been applied:

Run the below SQL proc by opening SQL Enterprise Manager 2008 and create a new query.   Put the FQDN of the DPM server in the query where specified.

use dpmdb

Update tbl_am_installedagent

Set ServerAttributes = 31

Where deleted = 0 and serverid in (select Serverid from
tbl_am_server where serverName = ‘RELACE_FQDN_HERE’)

 

After running this proc, try creating the PG. Note that this field will be reverted back again by the 30 min refresh job, but should not affect protection for data sources already
being protected.

More information:

http://blogs.technet.com/b/mattmcspirit/archive/2010/03/26/dpm-2010-rc-and-hyper-v-r2-vm-s-on-csv-s-order-of-patches.aspx