Here is an issue related to network and sharing center.
In some scenario, the network adapter icons are missing from Network and Sharing Center. But you can see the adapters in Device Manager and can access internet without issue even though a Red X at the notification area.

You uninstall and reinstall the NIC drivers, however, it does not work.

If you encounter this kind of problem, please follow the below step to resolve it.


1.    Please ensure the following registry key is not missing:
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Network\{4D36E972-E325-11CE-BFC1-08002BE10318}\{759F6019-7C4A-44BD-A9EC-7DC5393874C3}\Connection

Valuename: "Name"
Type: REG_SZ
If missing, created it with a value of "Local Area Connection"

Valuename: "DefaultNameIndex"
Type: REG_DWORD
If missing, Created it with a value of "0".

Valuename: "DefaultNameResourceId"
Type: REG_DWORD
If missing, created it with a value of "0x70b".

2. Ensure the following settings are correct:
1) "HKEY_CLASSES_ROOT\AppID\{27AF75ED-20D9-11D1-B1CE-00805FC1270E}", The default value is ‘netman’, and its subkey:

Valuename: LocalService
Value 'netman'


2) Component Services > Computers > my computer > DCOM Config > "Netman" -> Security tab -> Open "Launch and activation Permissions" -> edit,


add 'LOCAL SERVICE' with 'Local Launch' and 'Local Activation' checked.
add 'NETWORK SERVICE' with  'Local Launch' and 'Local Activation' checked"


3) Reboot the server after making the change.

You also can reference the link:
http://blogs.technet.com/b/juanand/archive/2010/01/11/the-case-of-windows-7-network-connections-empty-folder.aspx