Microsoft Reduce Customer Effort Center

Our team drives product feedback based on solid data, it drives proactive issue prevention and ultimately, drives improvements around products based on customer feedback.

System restore points are missing after Windows 7 reboot

System restore points are missing after Windows 7 reboot

  • Comments 1
  • Likes

Recently, we have been seeing a large number of threads from the forum that system restore points will disappear after windows 7 reboot.

When the issue happens, one or more of the following events could be logged:

Event ID 22
Volume Shadow Copy Service error: A critical component required by the Volume Shadow Copy service is not registered. This might happened if an error occurred during Windows setup or during installation of a Shadow Copy provider. The error returned from CoCreateInstance on class with CLSID {e579ab5f-1cc4-44b4-bed9-de0991ff0623} and Name IVssCoordinatorEx2 is [0x80040154, Class not registered].


Event ID 8193
Volume Shadow Copy Service error: Unexpected error calling routine CoCreateInstance.  hr = 0x80040154, Class not registered.


Event ID 25
The shadow copies of volume C: were deleted because the shadow copy storage could not grow in time.  Consider reducing the IO load on the system or choose a shadow copy storage volume that is not being shadow copied."


After investigation, we found this problem occurs due to several possible causes, we can use one of the following methods to resolve it:

1) Increase the size of shadow storage on the drive you are having issue with.

A.   Open a command prompt with administrator priviledge

B.   Type Vssadmin list shadowstorage

C.   Take note of what the shadow storage allocation is on the drive you're having issues with.

D.   Change the allocation by using the Vssadmin command, syntax: vssadmin resize shadowstorage /On=C: /For=C: /Maxsize=1G (where Maxsize=the amount of disk space you've allocated to System Restore points, you should increase it larger)

E.   After increasing the size and rebooting,

2) In some scenarios, 3rd party applications like Diskeeper can cause it. Please disable it to see if it can resolve the problem.

3) This problem can also be caused by corrupted ACLs for pagefiles.sys and hiberfil.sys. Please disable pagefile and hiberfil on your system, do a reboot to verify that these files have been deleted. Create restore points and verify that restore points persist across reboot. You can enable pagefile and hiberfil later.

4) Dual boot with Windows XP is also one of the possible causes. Please read the article KB926185 (http://support.microsoft.com/kb/926185) for more details.

The following forum links are for your reference.

http://social.answers.microsoft.com/Forums/en-US/w7repair/thread/6eb3551b-58d0-46de-83ab-214a0022716b

http://social.technet.microsoft.com/Forums/en-US/w7itprogeneral/thread/e97d2a1a-a3da-44f3-b531-6c230bd2410e

http://social.technet.microsoft.com/Forums/en/w7itprogeneral/thread/60701b85-7f61-4207-b82b-1143f5971cac

Edit: KB2506576 was published, please refer to it for more details. http://support.microsoft.com/kb/2506576

 

Comments
  • Apparently this happens as well when you dual boot Windows 7 and 8.  When you create a restore point in 8 and then boot to 7 and then back to 8, the restore point is gone. It also happens inn reverse.

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment