MBSA version 2.1 will fully support Windows Vista. The first beta version of MBSA 2.1 will be available in the first quarter of 2007. The full release version of MBSA 2.1 will be available in the third quarter of 2007.

But the current version of MBSA is version 2.0.1, which provides limited support for scanning computers that are running Windows Vista.

 

We recommend that you install MBSA 2.0.1 on a supported operating system. Then, scan Windows Vista-based computers remotely. MBSA 2.0.1 supports the following Windows operating systems:

Microsoft Windows Server 2003

Microsoft Windows XP

Microsoft Windows 2000

Vulnerability assessment (VA) scanning of Windows Vista-based computers is not supported. Disable VA scanning when you scan Windows Vista-based computers. If you do not disable VA scanning, MBSA 2.0.1 may return inaccurate results.

 

To support full Microsoft Update (MU) and Windows Server Update Service (WSUS) scans in Windows Vista, use one of the following methods:

Use the MBSA GUI

When you use the MBSA graphical user interface (GUI) to scan for updates, scan only Windows Vista-based computers that are not configured for WSUS. Or, scan by using only the Scan using Microsoft Update only option.

Use the MBSA command-line tool

When you use the MBSA command-line tool to scan for updates, scan only Windows Vista-based computers that are not configured for WSUS. Or, use the /catalog switch.

 

More information available:

l          KB931943

l          Microsoft Baseline Security Analyzer
http://www.microsoft.com/mbsa

l          How to use the Microsoft Baseline Security Analyzer
http://msdn2.microsoft.com/en-us/library/aa302360.aspx

l          How to implement patch management
http://msdn2.microsoft.com/en-us/library/aa302364.aspx

l          To download MBSA, version 2.0.1, visit the following Microsoft Download Center Web site: http://www.microsoft.com/downloads/details.aspx?FamilyId=4B4ABA06-B5F9-4DAD-BE9D-7B51EC2E5AC9&displaylang=en