Goatee PFE

Blog of Microsoft Premier Field Engineer Ashley McGlone featuring PowerShell scripts for Active Directory.

June, 2013

  • How To Use The 2012 Active Directory PowerShell Cmdlets From Windows 7

    Today we have several domain controller operating systems that support the Active Directory module cmdlets. Clients on Windows 7 and 8 can install the Remote Server Administration Tools (RSAT) to script with the Active Directory module against these DCs.

    With all of these versions now the first question that comes to mind is compatibility.

    • Are Windows 8 and Windows Server 2012 compatible with my existing AD PowerShell scripts?
    • Can I use the Windows 8 RSAT AD module against 2008 R2 or 2003 DCs?
    • Can I use the Windows 7 RSAT AD module against 2012 DCs?

    The Windows Server 2012 Active Directory PowerShell module has some handy new cmdlets.  However, many IT shops struggle to stay current on the latest operating system releases due to a variety of issues (budget, resources, compatibility, etc.). They desperately want to use the latest features, but their deployment standards have not caught up yet. This leaves them with workable, but sometimes inefficient, tools from previous releases.

    Today’s article will show you how to use the latest Windows Server PowerShell modules in a legacy Windows 7 environment.  As a bonus we’ll explore compatibility of the AD cmdlets across the different operating systems.