KBWe posted this solution a while back but it's proven to be so popular that it was converted to an official Knowledge Base article.  You can find our original post here but the test of the KB is below:

=====

Symptoms

Consider the following scenario:
1.  You install the App-v 4.x server and set the packageroot (content directory) to an alternate location (not the default).
2.  You delete the included Default Application, package and content from the disk.
3.  You upgrade the server to a newer version of App-V.
After completing the steps above, when clients attempt to stream a virtualized application they receive one of the following errors:

A network error occurred error :  XXXXXXXX-XXXXXXXX-20000194

or

The package requested could not be found in the system data store or the files associated with this package could not be found on the server.  Report the following error code to your System Administrator.
Error code: xxxxxxx-xxxxxx0A-20000194

Cause

This is caused by an invalid value for SOFTGRID_CONTENT_DIR in the registry.

Resolution

To resolve this issue complete the following steps:
1.  Start RegEdit
2.  Navigate to the following key:

32-bit Management Server: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SoftGrid\4.5\Server
64-bit Management Server: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\SoftGrid\4.5\Server

3. Set the SOFTGRID_CONTENT_DIR value to the proper content directory location.
4.  Restart the server.

More Information

During the server upgrade, the installer first searches for the defaultapp.sft file location. After getting the defaultapp.sft file path, the installer then gets the content directory path from the SOFTGRID_CONTENT_DIR registry key. If the defaultapp.sft file path is not the same as SOFTGRID_CONTENT_DIR registry entry, the installer overrides the value of SOFTGRID_CONTENT_DIR. If there is no defaultapp.sft file (i.e. it has been deleted), the installer overrides the value of SOFTGRID_CONTENT_DIR anyway with the default installation content directory (PROGRAM_FILES\Microsoft System Center App Virt Management Server\App Virt Management Server\Content).

For the latest version of the article see the link below:

KB2419521 - After upgrading a Microsoft App-V server, client machines may receive 0A-20000194 errors when trying to launch applications

J.C. Hornbeck | System Center Knowledge Engineer

The App-V Team blog: http://blogs.technet.com/appv/
The WSUS Support Team blog: http://blogs.technet.com/sus/
The SCMDM Support Team blog: http://blogs.technet.com/mdm/
The ConfigMgr Support Team blog: http://blogs.technet.com/configurationmgr/
The OpsMgr Support Team blog: http://blogs.technet.com/operationsmgr/
The SCVMM Team blog: http://blogs.technet.com/scvmm/
The MED-V Team blog: http://blogs.technet.com/medv/
The DPM Team blog: http://blogs.technet.com/dpm/
The OOB Support Team blog: http://blogs.technet.com/oob/
The Opalis Team blog: http://blogs.technet.com/opalis

clip_image001 clip_image002