The Microsoft App-V Team Blog

The official blog for Microsoft Application Virtualization

How to properly specify the SQL instance during the App-V 4.5 Management Server installation

How to properly specify the SQL instance during the App-V 4.5 Management Server installation

  • Comments 4
  • Likes

Here's another App-V 4.5 issue we saw during the beta.  This one was written up by Steve Thomas and concerns how to properly specify the SQL instance you want to use for the App-V 4.5 Management Server during installation.  If you're not using the default instance then you'll want to make a note of this one:

========

Issue: During installation of the Application Virtualization 4.5 Management Server, if you provide a server name\instance name for the SQL Server with a port number that is only valid for the Default Instance, then the Installer will connect to the Default Instance.  This will happen even if the Default Instance was not specified.

The reverse is also true in this scenario: If you try to connect to the Default Instance, but provide the port of a Named Instance, the installer will connect to the Named Instance database.

Cause: This functionality is by design. The problem only occurs when ServerName\InstanceName is entered in the "Host name" field as this field was never intended to support an instance name. 

Resolution:  To connect to an instance, you should provide the HostName of the database server and the TCP port number on which the instance is listening.  The InstanceName should not be provided as part of the HostName. 

========

Thanks Steve!

J.C. Hornbeck | Manageability Knowledge Engineer

Comments
  • Here's another App-V 4.5 issue we saw during the beta.  This one was written up by Steve Thomas

  • FW: How to properly specify the SQL instance during the App-V 4.5 Management Server installation Feed

  • I did the same however I fixed it using this approach

    in the ....app virtual management service folder look for this file sftmgmt.udl  and double click it, it will give you the chance to fix it here.  WooHoo I'm off and running now.

  • Hi, I am upgrading my App-V 5.0 server component to v5.0 SP1, I am not sure what to specify to upgrade the DB component to SP1. When I tried using the , , ..etc its failing with the error "Cannot connect to the SQL instance you specified. Please make sure that it exists, the database server is running, and that you have the necessary access rights." Please help!

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment