The Microsoft App-V Team Blog

The official blog for Microsoft Application Virtualization

"Resolve Partial Assembly failed" error when running sequenced application

"Resolve Partial Assembly failed" error when running sequenced application

  • Comments 2
  • Likes

Here's a cool issue recently uncovered by Paul Freitas, one of our Support Engineers for MS App Virtualization.  I hadn't come across this error before but if you see it this may be a good thing to check.

========

Issue: When an application is installed locally it runs fine, although when it's virtualized (sequenced) it generates the following error when launched:

Resolve Partial Assembly failed

Cause: This may occur if the same version of .NET Framework is installed locally as well as virtualized along with the application in the same package.

Resolution: The resolution is pretty obvious but I'll spell it out anyway - You need to either remove .NET Framework from the sequence or remove it from the client.  Either way will work.

Links: Just in case you're looking for the .NET Framework packages you can find them here:

Microsoft .NET Framework Version 1.1 Redistributable Package

Microsoft .NET Framework Version 2.0 Redistributable Package (x86)

Microsoft .NET Framework Version 2.0 Redistributable Package (x64)

Microsoft .NET Framework 3.0 Redistributable Package

Hopefully you won't run into this issue during your sequencing adventures but if you do be sure to check this out.

J.C. Hornbeck | Manageability Knowledge Engineer

Comments
Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment