If you happen to download the latest version of MDOP (SW_CD_Dsktp_Optimization_Pck_SA_2007_English_1_MLF_X13-63487.EXE) then you might notice that the softgrid-sequencer-setup.exe file reports being version 4.1.1 even though MDOP should include version 4.2.  Never fear, you really do have version 4.2, it's just that the setup file itself got mislabeled with the wrong version info.  Once you actually install the Sequencer you'll see that it's really 4.2.  Not sure how that one slipped through but hopefully this will eliminate any confusion.

J.C. Hornbeck