Installing Windows Service Pack (and some updates) fails on DPM Servers

Installing Windows Service Pack (and some updates) fails on DPM Servers

  • Comments 1
  • Likes

I've had two customers recently run into the issue of the installation of SP1 for Windows Server 2008 R2 failing on their Data Protection Manager (DPM) servers (in this case, DPM 2010 but same would apply to DPM 2007).

The problem arises because during the installation, driver-servicing will enumerate the driver information in the registry. There is a default time-out of 15 min for this process, however, on DPM servers where there is a large number of snapshots, it doesn't finish the enumeration process within the 15 min time period and therefore the SP1 install fails.

After engaging Premier Support, the work-around that my customers have successfully employed is as follows:

  1. On the server open the registry by running regedit.exe
  2. Navigate to HKLM\System\CurrentControlSet\Services\TrustedInstaller
  3. Find the registry value BlockTimeIncrement. By default this is set to 384 (15 min); change it to 2a30 (3 hours). If you receive an error while trying to change the value you may need to change the permissions on the TrustedInstaller key to Full Control for Users.
  4. Reboot the server, then install SP1.

My customers found that it took anywhere between 25 mins and 1.5 hours for the SP1 install to complete depending on the number of snapshots. After the SP1 install is complete you can either revert the change or leave it in place.

 

Comments
  • Its already 3 hours and stuck on Configuring Service Pack 9% complete. Is there anything I need to do or shall I just wait?

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment