SharePoint 2007: "Open in Explorer View" with Windows 7 and IE8 is Extremely Slow

SharePoint 2007: "Open in Explorer View" with Windows 7 and IE8 is Extremely Slow

  • Comments 2
  • Likes

I worked with a customer today who was experiencing extreme delays when using the "Explorer View" in Microsoft Office SharePoint Server 2007 on a Windows 7 machine with Internet Explorer 8. After clicking on either "Actions - Open in Explorer View" or changing the view to "Explorer View", the following message would be shown in the SharePoint Document library pane.

"Please wait while Explorer View is loaded. If Explorer View does not appear, your browser may not support it"

The first delay would last up to about eight (8) minutes and then would prompt for credentials. After the credentials were entered, it took about another five (5) minutes for the explorer view to appear. The delays were taking up to 14 minutes from start to finish - this is unacceptable!!!! The customer was also accessing the sites using "https" and not "http".

After doing a lot of research both internally and via the Internet, we came up with the following procedure that resolves this issue.

Internet Explorer 8 Changes

The following changes will speed up the process to open explorer view

  1. Add the SharePoint site to Trusted Sites

    1. In IE8, click Tools -> Internet Options

    2. Select the Security tab

    3. Select the Trusted sites green check mark

    4. Click the Sites button

    5. Enter the URL (if not already there) in the "Add this website to the zone" field then select the Add button

  2. Select CloseEnable launching programs and files in an IFRAME

    1. While still in the security tab, click the Custom Level button

    2. Scroll down in the Settings dialog box until you find "Launching programs and files in an IFRAME". Click the Enable radio button then click OK
  3. Disable Proxies

    1. While still in IE8, click the Connections tab then select the LAN Settings button

    2. Uncheck the following boxes:

      1. Automatically detect settings

      2. Use automatic configuration script

    3. Click OK twice to close Internet Explorer Options

Registry Changes

These changes need to be made if you are accessing a site using "https" so it doesn't prompt for your credentials. This information is taken from http://support.microsoft.com/KB/943280

  1. Modify a Registry file
    1. Go to Start -> Run (or Start -> Search Programs and Files) and type in Regedit and press Enter

    2. Locate then click the following Registry subkey

      1. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters

    3. On the Edit menu, point to New then click Multi-String Value

    4. Type AuthForwardServerList and press Enter

    5. On the Edit menu, click Modify

    6. In the Value data box, type the URL of the server that hosts the Web share then click OK

    7. Exit Registry Editor

    8. Reboot the machine

Hopefully this will save others from spending un-due time on searching for the solution and a SPECIAL THANKS to Jeffrey J Blasinski for testing and confirming these steps!

 

Comments
  • Jeff got published!  :)

  • Perfect!!!

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment