Exchange 2007 - Mail queuing/backing up in Submission queue. A Transport agent problem?

Exchange 2007 - Mail queuing/backing up in Submission queue. A Transport agent problem?

  • Comments 1
  • Likes

So, this can happen for a variety of reasons, is it a spike and busy time? Are disks getting hit/not performing well? Or as occasionally we can see messages, arent going through the Categorizer and into delivery due to a bad transport agent.

 

We can show the power of Powershell here and run some nifty commands.

 

First "get-queue Submission" to ensure the queue isnt suspended.

 

If we run "get-message -Filter: {Queue -eq 'Submission' -and Status -eq 'Active'} | ft"

 

We can see the messages that are currently in the categorizer, by default the cat only processes 20 messages at once. If we run this command several times, perhaps over the course of a few minutes we can conclude that the submision queue is indeed stuck. The likelihood is this is a stuck cat agent.

 

As a method to get mailflow back asap, although this isnt always possible we did a "get-transportagent" to see what agents are present and enabled.

Through a process of elimination use "disable-transportagent" and "enable-transportagent" to establish what was causing the headache. With the problem transport agent isolated and disabled mailflow can be returned.

Comments
  • Hello, nice article! I am trying to run: get-message -Filter: {Queue -eq 'Submission' -and Status -eq 'Active'} | ft on my Exchange 2010 server but nothing happens when I do this... do I need to add some diff parameters?

    Thanks!

Your comment has been posted.   Close
Thank you, your comment requires moderation so it may take a while to appear.   Close
Leave a Comment