How many of you have migrated to Exchange 2003 from Exchange 2000? I guess that too many people have done that and specially Front-End Servers (obviously... are the first component to be migrated)... But how many of you have faced the situation when the setup starts the migration process and then suddenly hangs (apparently) with no particular reason at all. 

When you review the Exchange Setup log, you find that the following entries are the last ones (if the setup process has not been canceled):

[17:46:07] Reading ACL from directory "C:\Program Files"
[17:46:07] Tweaking bits on the ACL
[17:46:07] Stamping ACL on "E:\Program Files\Exchsrvr"

Also in the progress bar of the Exchange setup you have the following process running:

Configuring registry entries for Required machine-level settings

Well... this just has happened to me... everything was going well, actually I was thinking that it was going to be a smooth migration but ohh surprise... do you know what else we have to consider?? no more suspense...  if your front-end server is also an SMTP box... then you have to verify that your Badmail folder is not high populated (thousands and thousands and thousands small files), in that case before start with the setup you have to move those files to a separate location (out of E:\Program Files\Exchsrvr) or delete them. Otherwise it will take long long time (in my escenario about 7 hrs) to complete the stamping process. If you would like to review the KB which talk more about it, refer to the following site for more details:

Setup stops working during an upgrade from Exchange 2000 Server to Exchange Server 2003

Good luck in your next migration and don't forget to consider this as one of the pre-migration tasks in your procedures!!!